summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2003-09-22 19:50:14 -0700
committerTim Rice <tim@multitalents.net>2003-09-22 19:50:14 -0700
commit7ff4e6dbe588aab63f1547e917734730f388aaa4 (patch)
tree1d0050ec23a81f2d883d7a53326e960d45ae61ff /configure.ac
parentda4d9cf4bfc34052f60e7161abbe7b88517ab43a (diff)
[configure.ac] add --disable-etc-default-login option. ok djm
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ac1a4d9f..dbb08fbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.164 2003/09/22 04:38:11 tim Exp $
+# $Id: configure.ac,v 1.165 2003/09/23 02:50:14 tim Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -2215,11 +2215,15 @@ else
fi
# check for /etc/default/login and use it if present.
+AC_ARG_ENABLE(etc-default-login,
+ [ --disable-etc-default-login Disable using PATH from /etc/default/login [no]],,
+[
AC_CHECK_FILE("/etc/default/login", [ external_path_file=/etc/default/login ])
if test "x$external_path_file" = "x/etc/default/login"; then
AC_DEFINE(HAVE_ETC_DEFAULT_LOGIN)
fi
+])
dnl BSD systems use /etc/login.conf so --with-default-path= has no effect
if test $ac_cv_func_login_getcapbool = "yes" -a \