summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-06-29 21:30:41 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-06-29 21:30:41 +1000
commit6eb9304782a7404fca406f742d4546e55c8dc1c7 (patch)
tree8ec48dd80c804ea3f77e7bd132074200e583ba14 /configure.ac
parentcc9fd54a3636d98dbada76f71bd5e6e82495f9c0 (diff)
- (dtucker) [configure.ac] Add sanity test after system-dependant compiler
flag modifications.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0992744c..bf00443a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.128 2003/06/28 02:54:33 dtucker Exp $
+# $Id: configure.ac,v 1.129 2003/06/29 11:30:41 dtucker Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -438,6 +438,18 @@ AC_ARG_WITH(libs,
]
)
+AC_MSG_CHECKING(compiler and flags for sanity)
+AC_TRY_RUN([
+#include <stdio.h>
+int main(){exit(0);}
+ ],
+ [ AC_MSG_RESULT(yes) ],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([*** compiler cannot create working executables, check config.log ***])
+ ]
+)
+
# Checks for header files.
AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \
getopt.h glob.h ia.h lastlog.h libgen.h limits.h login.h \