summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2002-06-28 00:37:33 +0000
committerBen Lindstrom <mouring@eviladmin.org>2002-06-28 00:37:33 +0000
commit68e831132128d8987462b44808fcd078ea7d83bb (patch)
tree14ee660cc18e9dc6f324a41ee4a09427f3e76387 /configure.ac
parentdd21fe9ca0293264924d9045e7a9aab1e7f31f28 (diff)
- (bal) FreeBSD needs <sys/types.h> to detect if mmap() is supported.
Bug #303
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ad5d5cde..7ef77e5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.72 2002/06/25 22:35:16 tim Exp $
+# $Id: configure.ac,v 1.73 2002/06/28 00:37:33 mouring Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -582,6 +582,7 @@ AC_MSG_CHECKING([for mmap anon shared])
AC_TRY_RUN(
[
#include <stdio.h>
+#include <sys/types.h>
#include <sys/mman.h>
#if !defined(MAP_ANON) && defined(MAP_ANONYMOUS)
#define MAP_ANON MAP_ANONYMOUS