summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-05-02 20:48:21 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-05-02 20:48:21 +1000
commit3c01654deb235191d798a5254561624872a7f010 (patch)
tree71ae1572d4f5440888b9f3ddc1c7ef7512dc7ab6 /configure.ac
parenteab4bae03894f07ea556db4d781795c724245af7 (diff)
- (dtucker) Bug #544: ignore invalid cmsg_type on Linux 2.0 kernels,
privsep should now work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 38cc4d40..d6726eaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.114 2003/04/29 13:22:40 djm Exp $
+# $Id: configure.ac,v 1.115 2003/05/02 10:48:21 dtucker Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -188,6 +188,16 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
AC_DEFINE(SETPROCTITLE_STRATEGY,PS_USE_CLOBBER_ARGV)
AC_DEFINE(SETPROCTITLE_PS_PADDING, '\0')
inet6_default_4in6=yes
+ AC_MSG_CHECKING(for broken cmsg_type)
+ case `uname -r` in
+ 2.0.*)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(BROKEN_CMSG_TYPE)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac
;;
mips-sony-bsd|mips-sony-newsos4)
AC_DEFINE(HAVE_NEWS4)