summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-07-19 19:49:45 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-07-19 19:49:45 +1000
commit394b8c8db307fa4d4c39ecb4d276980ce9927146 (patch)
tree969beff2261cbca46b0d5d5fdead5ed8d4a09a35 /configure.ac
parent1a721156b0a7f86e2d431735be8b8a3cd7803b3f (diff)
- (dtucker) [configure.ac] Bug #620: Define BROKEN_GETADDRINFO for
Solaris/x86. Patch from jrhett at isite.net.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 516a2443..4501b4ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.134 2003/07/14 06:41:55 dtucker Exp $
+# $Id: configure.ac,v 1.135 2003/07/19 09:49:45 dtucker Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -296,6 +296,10 @@ mips-sony-bsd|mips-sony-newsos4)
else
AC_MSG_RESULT(no)
fi
+ sol2platform=`echo "$host"| sed -e 's/-solaris.*$//'`
+ if test "$sol2platform" -eq "i386-pc"; then
+ AC_DEFINE(BROKEN_ADDRINFO)
+ fi
;;
*-*-sunos4*)
CPPFLAGS="$CPPFLAGS -DSUNOS4"