summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2005-06-02 20:28:29 -0700
committerTim Rice <tim@multitalents.net>2005-06-02 20:28:29 -0700
commitfcc7ff1de8db0647357a5846e4d629f4ca54a6b9 (patch)
tree9115ef0b1fe1f11321bd4d7dbf2aab87ac6d9c82 /configure.ac
parent4dbacffe7bd6160c66c89093969eba469fb90b55 (diff)
- (tim) [configure.ac] Some platforms need sys/types.h for arpa/nameser.h.
Take AC_CHECK_HEADERS test out of ultrix section. It caused other platforms to skip builtin standard includes tests. (first AC_CHECK_HEADERS test must be run on all platforms) Add missing ;; to case statement. OK dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 61132acd..bca35a63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.271 2005/06/02 03:09:28 tim Exp $
+# $Id: configure.ac,v 1.272 2005/06/03 03:28:29 tim Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -479,7 +479,8 @@ mips-sony-bsd|mips-sony-newsos4)
AC_DEFINE(BROKEN_GETGROUPS, [], [getgroups(0,NULL) will return -1])
AC_DEFINE(BROKEN_MMAP, [], [Ultrix mmap can't map files])
AC_DEFINE(NEED_SETPRGP, [], [Need setpgrp to acquire controlling tty])
- AC_CHECK_HEADERS(sys/syslog.h)
+ AC_DEFINE(HAVE_SYS_SYSLOG_H, 1, [Force use of sys/syslog.h on Ultrix])
+ ;;
esac
# Allow user to specify flags
@@ -2540,7 +2541,8 @@ int main()
])
AC_CHECK_FUNCS(_getshort _getlong)
AC_CHECK_DECLS([_getshort, _getlong], , ,
- [#include <arpa/nameser.h>])
+ [#include <sys/types.h>
+ #include <arpa/nameser.h>])
AC_CHECK_MEMBER(HEADER.ad,
[AC_DEFINE(HAVE_HEADER_AD)],,
[#include <arpa/nameser.h>])