summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2005-08-23 17:11:26 -0700
committerTim Rice <tim@multitalents.net>2005-08-23 17:11:26 -0700
commit3db1e3fc685cb0c570b4e17a60e0e041fa48b32f (patch)
tree5fa4583ce7748e6a064ad5e4dbf171eacee55628 /configure.ac
parent114572f7ee4acd2aab331784f658851e5fbad9a4 (diff)
- (tim) [configure.ac ] Not all gcc's support -Wsign-compare
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 619a4e76..f1588c69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.287 2005/08/22 22:06:56 dtucker Exp $
+# $Id: configure.ac,v 1.288 2005/08/24 00:11:26 tim Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -82,7 +82,13 @@ AC_CHECK_DECL(LLONG_MAX, have_llong_max=1, , [#include <limits.h>])
if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wuninitialized"
- CFLAGS="$CFLAGS -Wsign-compare"
+ GCC_VER=`$CC --version`
+ case $GCC_VER in
+ 1.*) ;;
+ 2.8* | 2.9*) CFLAGS="$CFLAGS -Wsign-compare" ;;
+ 2.*) ;;
+ *) CFLAGS="$CFLAGS -Wsign-compare" ;;
+ esac
if test -z "$have_llong_max"; then
# retry LLONG_MAX with -std=gnu99, needed on some Linuxes