summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-10-16 14:45:57 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-10-16 14:45:57 +1100
commit1673274aee67ce0eb6f00578b6f3d2bcbd58f937 (patch)
tree2e893928cc16cdc5b8fdb58034416ef751307bf9 /configure.ac
parent4e23deefd7959ef83c73ed9cce574423438f6133 (diff)
Remove gcc spectre mitigation flags.
Current impementions of the gcc spectre mitigation flags cause miscompilations when combined with other flags and do not provide much protection. Found by fweimer at redhat.com, ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 9dacccb2..099ecdaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,15 +164,6 @@ if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
OSSH_CHECK_CFLAG_COMPILE([-Wunused-result], [-Wno-unused-result])
OSSH_CHECK_CFLAG_COMPILE([-fno-strict-aliasing])
if test "x$use_toolchain_hardening" = "x1"; then
- # Cygwin GCC 7.x allows thunking on the CLI, but produces non-working
- # code. Unfortunately you only notice this at link time.
- case "$host" in
- *-*-cygwin*) ;;
- *)
- OSSH_CHECK_CFLAG_COMPILE([-mfunction-return=thunk]) # gcc
- OSSH_CHECK_CFLAG_COMPILE([-mindirect-branch=thunk]) # gcc
- ;;
- esac
OSSH_CHECK_CFLAG_COMPILE([-mretpoline]) # clang
OSSH_CHECK_LDFLAG_LINK([-Wl,-z,retpolineplt])
OSSH_CHECK_CFLAG_COMPILE([-D_FORTIFY_SOURCE=2])