summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-02-26 12:51:29 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-02-27 15:28:31 +1100
commit146c3bd28c8dbee9c4b06465d9c9facab96b1e9b (patch)
treea850a0e7e674736859f4ff9165de0571e5c34f61 /configure.ac
parent1323f120d06a26074c4d154fcbe7f49bcad3d741 (diff)
Check dlopen has RTLD_NOW before enabling pkcs11.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0ba2ff44..7e6e1ebd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1876,7 +1876,10 @@ AC_ARG_ENABLE([pkcs11],
if test "x$openssl" = "xyes" && test "x$disable_pkcs11" = "x"; then
# PKCS#11 support requires dlopen() and co
AC_SEARCH_LIBS([dlopen], [dl],
- [AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])]
+ AC_CHECK_DECL([RTLD_NOW],
+ AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support]),
+ [], [#include <dlfcn.h>]
+ )
)
fi