summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2017-05-24 23:21:19 -0400
committerDamien Miller <djm@mindrot.org>2017-05-25 14:34:52 +1000
commitdcc714c65cfb81eb6903095b4590719e8690f3da (patch)
tree363ff3be7fd2cabb2a7501619639eaeae40bc9b6 /configure.ac
parent947a3e829a5b8832a4768fd764283709a4ca7955 (diff)
configure: actually set cache vars when cross-compiling
The cross-compiling fallback message says it's assuming the test passed, but it didn't actually set the cache var which causes later tests to fail.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5cfea38c..895c5211 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3162,7 +3162,8 @@ AC_RUN_IFELSE(
select_works_with_rlimit=yes],
[AC_MSG_RESULT([no])
select_works_with_rlimit=no],
- [AC_MSG_WARN([cross compiling: assuming yes])]
+ [AC_MSG_WARN([cross compiling: assuming yes])
+ select_works_with_rlimit=yes]
)
AC_MSG_CHECKING([if setrlimit(RLIMIT_NOFILE,{0,0}) works])
@@ -3188,7 +3189,8 @@ AC_RUN_IFELSE(
rlimit_nofile_zero_works=yes],
[AC_MSG_RESULT([no])
rlimit_nofile_zero_works=no],
- [AC_MSG_WARN([cross compiling: assuming yes])]
+ [AC_MSG_WARN([cross compiling: assuming yes])
+ rlimit_nofile_zero_works=yes]
)
AC_MSG_CHECKING([if setrlimit RLIMIT_FSIZE works])