summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-02-22 20:45:09 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-02-22 21:00:06 +1100
commitce066f688dc166506c082dac41ca686066e3de5f (patch)
tree97ef804885643a41dd0eb13c990eee63569b9db7 /configure.ac
parent3fd2d2291a695c96a54269deae079bacce6e3fb9 (diff)
Add headers for sys/audit.h.
On some older platforms (at least sunos4, probably others) sys/audit.h requires some other headers. Patch from klausz at haus-gisela.de.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 810f96ca..cbcf9d07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,12 +388,12 @@ AC_CHECK_HEADERS([ \
stdint.h \
string.h \
strings.h \
- sys/audit.h \
sys/bitypes.h \
sys/bsdtty.h \
sys/cdefs.h \
sys/dir.h \
sys/mman.h \
+ sys/label.h \
sys/ndir.h \
sys/poll.h \
sys/prctl.h \
@@ -422,6 +422,20 @@ AC_CHECK_HEADERS([ \
wchar.h \
])
+# On some platforms (eg SunOS4) sys/audit.h requires sys/[time|types|label.h]
+# to be included first.
+AC_CHECK_HEADERS([sys/audit.h], [], [], [
+#ifdef HAVE_SYS_TIME_H
+# include <sys/time.h>
+#endif
+#ifdef HAVE_SYS_TYPES_H
+# include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_LABEL_H
+# include <sys/label.h>
+#endif
+])
+
# sys/capsicum.h requires sys/types.h
AC_CHECK_HEADERS([sys/capsicum.h], [], [], [
#ifdef HAVE_SYS_TYPES_H