summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2004-02-18 11:21:12 +1100
committerDarren Tucker <dtucker@zip.com.au>2004-02-18 11:21:12 +1100
commita22897df0689d19e3fcd0d791fb63b49aa95c1cb (patch)
treece187f8306b19054046cd8ffcc032f410c95ad77 /configure.ac
parent5cf8ef735c5d7d76c1c69e491419b1311ec1575b (diff)
- (dtucker) [configure.ac] Handle case where krb5-config --libs returns a
path with a "-" in it. From Sergio.Gelato at astro.su.se.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6b1c3137..601cd753 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.198 2004/02/12 17:27:21 tim Exp $
+# $Id: configure.ac,v 1.199 2004/02/18 00:21:12 dtucker Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -2085,9 +2085,9 @@ AC_ARG_WITH(kerberos5,
if $KRB5CONF | grep gssapi >/dev/null ; then
AC_MSG_RESULT(yes)
K5CFLAGS="`$KRB5CONF --cflags gssapi`"
- dnl m4 quadragraphs: "sed 's/-l[^- ]*//g'"
- K5LDFLAGS="`$KRB5CONF --libs gssapi | sed 's/-l@<:@^- @:>@*//g'`"
- K5LIBS="`$KRB5CONF --libs gssapi | sed 's/-L@<:@^- @:>@*//g'`"
+ dnl m4 quadragraphs: "sed 's/-l[^ ]* //g'"
+ K5LDFLAGS="`$KRB5CONF --libs gssapi | sed 's/-l@<:@^ @:>@* //g'`"
+ K5LIBS="`$KRB5CONF --libs gssapi | sed 's/-L@<:@^ @:>@* //g'`"
else
AC_MSG_RESULT(no)
K5CFLAGS="`$KRB5CONF --cflags`"