summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2004-02-12 09:27:21 -0800
committerTim Rice <tim@multitalents.net>2004-02-12 09:27:21 -0800
commit3d5352e1561174adca1df4336358d1847190d107 (patch)
tree9ac74e428fb5d61d49b5621a89b3b3f58c4781bf /configure.ac
parent9ad7e0e805157ad7374fe91dc20e6d0b2cc9ebf1 (diff)
[configure.ac] Make sure -lcrypto is before -lsocket for sco3. ok mouring@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 91a4c4ee..6b1c3137 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.197 2004/02/11 22:46:40 tim Exp $
+# $Id: configure.ac,v 1.198 2004/02/12 17:27:21 tim Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1021,12 +1021,6 @@ if test "x$PAM_MSG" = "xyes" ; then
)
fi
-# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
-# because the system crypt() is more featureful.
-if test "x$check_for_libcrypt_before" = "x1"; then
- AC_CHECK_LIB(crypt, crypt)
-fi
-
# Search for OpenSSL
saved_CPPFLAGS="$CPPFLAGS"
saved_LDFLAGS="$LDFLAGS"
@@ -1055,7 +1049,7 @@ AC_ARG_WITH(ssl-dir,
fi
]
)
-LIBS="$LIBS -lcrypto"
+LIBS="-lcrypto $LIBS"
AC_TRY_LINK_FUNC(RAND_add, AC_DEFINE(HAVE_OPENSSL),
[
dnl Check default openssl install dir
@@ -1157,6 +1151,12 @@ Also see contrib/findssl.sh for help identifying header/library mismatches.])
]
)
+# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
+# because the system crypt() is more featureful.
+if test "x$check_for_libcrypt_before" = "x1"; then
+ AC_CHECK_LIB(crypt, crypt)
+fi
+
# Some Linux systems (Slackware) need crypt() from libcrypt, *not* the
# version in OpenSSL.
if test "x$check_for_libcrypt_later" = "x1"; then