summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2017-10-25 11:25:43 +1100
committerDamien Miller <djm@mindrot.org>2017-10-25 13:11:37 +1100
commit3235473bc8e075fad7216b7cd62fcd2b0320ea04 (patch)
tree8be4956dd03e0e7467402911750005c35a908ccb /configure.ac
parent4d5456c7de108e17603a0920c4d15bca87244921 (diff)
check for net/route.h and sys/sysctl.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 889f5063..455a224e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -404,6 +404,7 @@ AC_CHECK_HEADERS([ \
sys/strtio.h \
sys/statvfs.h \
sys/sysmacros.h \
+ sys/sysctl.h \
sys/time.h \
sys/timers.h \
time.h \
@@ -427,6 +428,11 @@ AC_CHECK_HEADERS([sys/capsicum.h], [], [], [
#endif
])
+# net/route.h requires sys/socket.h
+AC_CHECK_HEADERS([net/route.h], [], [], [
+#include <sys/socket.h>
+])
+
# lastlog.h requires sys/time.h to be included first on Solaris
AC_CHECK_HEADERS([lastlog.h], [], [], [
#ifdef HAVE_SYS_TIME_H