summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2017-05-01 09:55:56 +1000
committerDamien Miller <djm@mindrot.org>2017-05-01 10:05:07 +1000
commitf7849e6c83a4e0f602dea6c834a24091c622d68e (patch)
treea9613115a359687db43ec553591f2fe3e3d9e4f6 /configure.ac
parentf4a6a88ddb6dba6d2f7bfb9e2c9879fcc9633043 (diff)
remove configure --with-ssh1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 0 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index f7a04d55..5cfea38c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,13 +109,10 @@ AC_CHECK_DECL([PR_SET_NO_NEW_PRIVS], [have_linux_no_new_privs=1], , [
])
openssl=yes
-ssh1=no
-COMMENT_OUT_RSA1="#no ssh1#"
AC_ARG_WITH([openssl],
[ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ],
[ if test "x$withval" = "xno" ; then
openssl=no
- ssh1=no
fi
]
)
@@ -127,31 +124,6 @@ else
AC_MSG_RESULT([no])
fi
-AC_ARG_WITH([ssh1],
- [ --with-ssh1 Enable support for SSH protocol 1],
- [
- if test "x$withval" = "xyes" ; then
- if test "x$openssl" = "xno" ; then
- AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled])
- fi
- ssh1=yes
- COMMENT_OUT_RSA1=""
- elif test "x$withval" = "xno" ; then
- ssh1=no
- else
- AC_MSG_ERROR([unknown --with-ssh1 argument])
- fi
- ]
-)
-AC_MSG_CHECKING([whether SSH protocol 1 support is enabled])
-if test "x$ssh1" = "xyes" ; then
- AC_MSG_RESULT([yes])
- AC_DEFINE_UNQUOTED([WITH_SSH1], [1], [include SSH protocol version 1 support])
- AC_SUBST([COMMENT_OUT_RSA1])
-else
- AC_MSG_RESULT([no])
-fi
-
use_stack_protector=1
use_toolchain_hardening=1
AC_ARG_WITH([stackprotect],