summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2016-08-16 13:30:56 +1000
committerDamien Miller <djm@mindrot.org>2016-08-16 13:37:26 +1000
commit8bd81e1596ab1bab355146cb65e82fb96ade3b23 (patch)
tree7c4872c8daf8171b0e84a4363b2ce0dc80b22e0b /configure.ac
parent74433a19bb6f4cef607680fa4d1d7d81ca3826aa (diff)
add --with-pam-service to specify PAM service name
Saves messing around with CFLAGS to do it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0837475..1f1941a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3047,6 +3047,17 @@ AC_ARG_WITH([pam],
]
)
+AC_ARG_WITH([pam-service],
+ [ --with-pam-service=name Specify PAM service name ],
+ [
+ if test "x$withval" != "xno" && \
+ test "x$withval" != "xyes" ; then
+ AC_DEFINE_UNQUOTED([SSHD_PAM_SERVICE],
+ ["$withval"], [sshd PAM service name])
+ fi
+ ]
+)
+
# Check for older PAM
if test "x$PAM_MSG" = "xyes" ; then
# Check PAM strerror arguments (old PAM)