summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2016-02-23 12:56:59 +1100
committerDamien Miller <djm@mindrot.org>2016-02-23 12:58:53 +1100
commit39f303b1f36d934d8410b05625f25c7bcb75db4d (patch)
tree46f6c9d07b32f1eb86d0839a0a501eb8c65d0fe1 /configure.ac
parent0d1451a32c7436e6d3d482351e776bc5e7824ce4 (diff)
fix sandbox on OSX Lion
sshd was failing with: ssh_sandbox_child: sandbox_init: dlopen(/usr/lib/libsandbox.1.dylib, 261):cw image not found [preauth] caused by chroot before sandboxing. Avoid by explicitly linking libsandbox to sshd. Spotted by Darren.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e36b0494..7258cc0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,6 +644,9 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
supported by bsd-setproctitle.c])
AC_CHECK_FUNCS([sandbox_init])
AC_CHECK_HEADERS([sandbox.h])
+ AC_CHECK_LIB([sandbox], [sandbox_apply], [
+ SSHDLIBS="$SSHDLIBS -lsandbox"
+ ])
;;
*-*-dragonfly*)
SSHDLIBS="$SSHDLIBS -lcrypt"