summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2016-08-01 14:31:52 -0700
committerTim Rice <tim@multitalents.net>2016-08-01 14:31:52 -0700
commitcf3e0be7f5828a5e5f6c296a607d20be2f07d60c (patch)
tree01964a9c47f5e31a9f74c8e0f0868c428e2249b8 /configure.ac
parent99522ba7ec6963a05c04a156bf20e3ba3605987c (diff)
modified: configure.ac opensshd.init.in
Skip generating missing RSA1 key on startup unless ssh1 support is enabled. Spotted by Jean-Pierre Radley
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 373d21b3..7c1956dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,6 +123,7 @@ AC_CHECK_DECL([PR_SET_NO_NEW_PRIVS], [have_linux_no_new_privs=1], , [
openssl=yes
ssh1=no
+COMMENT_OUT_RSA1="#no ssh1#"
AC_ARG_WITH([openssl],
[ --without-openssl Disable use of OpenSSL; use only limited internal crypto **EXPERIMENTAL** ],
[ if test "x$withval" = "xno" ; then
@@ -147,6 +148,7 @@ AC_ARG_WITH([ssh1],
AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled])
fi
ssh1=yes
+ COMMENT_OUT_RSA1=""
elif test "x$withval" = "xno" ; then
ssh1=no
else
@@ -158,6 +160,7 @@ AC_MSG_CHECKING([whether SSH protocol 1 support is enabled])
if test "x$ssh1" = "xyes" ; then
AC_MSG_RESULT([yes])
AC_DEFINE_UNQUOTED([WITH_SSH1], [1], [include SSH protocol version 1 support])
+ AC_SUBST([COMMENT_OUT_RSA1])
else
AC_MSG_RESULT([no])
fi