summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-03-30 18:23:07 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-03-30 18:23:07 +1100
commit2c71ca1dd1efe458cb7dee3f8a1a566f913182c2 (patch)
tree4906d911bcd351c9113675939ab9bd89b30753ae /configure.ac
parent6b5a17bc14e896e3904dc58d889b58934cfacd24 (diff)
Disable native strndup and strnlen on AIX.
On at least some revisions of AIX, strndup returns unterminated strings under some conditions, apparently because strnlen returns incorrect values in those cases. Disable both on AIX and use the replacements from openbsd-compat. Fixes problem with ECDSA keys there, ok djm.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bedacc2d..663062be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -603,6 +603,8 @@ case "$host" in
[AIX 5.2 and 5.3 (and presumably newer) require this])
AC_DEFINE([PTY_ZEROREAD], [1], [read(1) can return 0 for a non-closed fd])
AC_DEFINE([PLATFORM_SYS_DIR_UID], 2, [System dirs owned by bin (uid 2)])
+ AC_DEFINE([BROKEN_STRNDUP], 1, [strndup broken, see APAR IY61211])
+ AC_DEFINE([BROKEN_STRNLEN], 1, [strnlen broken, see APAR IY62551])
;;
*-*-android*)
AC_DEFINE([DISABLE_UTMP], [1], [Define if you don't want to use utmp])