summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2015-11-10 11:14:47 +1100
committerDarren Tucker <dtucker@zip.com.au>2015-11-10 11:14:47 +1100
commit1560596f44c01bb0cef977816410950ed17b8ecd (patch)
tree0a60f1dcf9d410ccec8a77f9b0c380d498ad08b6 /configure.ac
parente72a8575ffe1d8adff42c9abe9ca36938acc036b (diff)
Fix compiler warnings in the openssl header check.
Noted by Austin English.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a6f947eb..1527a13d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2345,6 +2345,7 @@ if test "x$openssl" = "xyes" ; then
AC_MSG_CHECKING([OpenSSL header version])
AC_RUN_IFELSE(
[AC_LANG_PROGRAM([[
+ #include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <openssl/opensslv.h>
@@ -2357,7 +2358,8 @@ if test "x$openssl" = "xyes" ; then
if(fd == NULL)
exit(1);
- if ((rc = fprintf(fd ,"%08x (%s)\n", OPENSSL_VERSION_NUMBER, OPENSSL_VERSION_TEXT)) <0)
+ if ((rc = fprintf(fd ,"%08lx (%s)\n",
+ (unsigned long)OPENSSL_VERSION_NUMBER, OPENSSL_VERSION_TEXT)) <0)
exit(1);
exit(0);