summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2010-02-12 10:11:34 +1100
committerDamien Miller <djm@mindrot.org>2010-02-12 10:11:34 +1100
commitb3c9f78711bde96415d22046af2c0f8c071a7e6f (patch)
tree2d0ca346265264f2774a1b8f2c3e647d6e22f6e0 /configure.ac
parentdfa4156dbd4aa45464b2ea6b867bcaa483bed134 (diff)
- (djm) [configure.ac] Enable PKCS#11 support only when we find a working
dlopen()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 40b58c64..f4c25683 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.442 2010/02/11 22:34:22 djm Exp $
+# $Id: configure.ac,v 1.443 2010/02/11 23:11:34 djm Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.442 $)
+AC_REVISION($Revision: 1.443 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -1420,6 +1420,11 @@ AC_CHECK_FUNCS( \
waitpid \
)
+# PKCS#11 support requires dlopen() and co
+AC_SEARCH_LIBS(dlopen, dl,
+ AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])
+)
+
# IRIX has a const char return value for gai_strerror()
AC_CHECK_FUNCS(gai_strerror,[
AC_DEFINE(HAVE_GAI_STRERROR)
@@ -4130,10 +4135,6 @@ else
AC_SUBST(TEST_SSH_IPV6, yes)
fi
-if test "x$enable_pkcs11" != "xno" ; then
- AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])
-fi
-
AC_EXEEXT
AC_CONFIG_FILES([Makefile buildpkg.sh opensshd.init openssh.xml \
openbsd-compat/Makefile openbsd-compat/regress/Makefile \