summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2007-12-02 21:02:22 +1100
committerDarren Tucker <dtucker@zip.com.au>2007-12-02 21:02:22 +1100
commit319b3d9b00a38d0b7d6965173f3507e80bb1f46e (patch)
tree7127e097d5ad3d30e8cc25b279c4a538b5c3824d /configure.ac
parente6d152794949c1e552e154aef6c74ef867991a9b (diff)
- (dtucker) [configure.ac] Enable -fstack-protector-all on systems where
gcc supports it. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e9402a73..c9bce019 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.386 2007/09/26 21:03:20 dtucker Exp $
+# $Id: configure.ac,v 1.387 2007/12/02 10:02:22 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.386 $)
+AC_REVISION($Revision: 1.387 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -105,6 +105,15 @@ if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
*) ;;
esac
+ AC_MSG_CHECKING(if $GCC understands -fstack-protector-all)
+ saved_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS -fstack-protector-all"
+ AC_TRY_COMPILE([], [ int main(void){return 0;} ],
+ [ AC_MSG_RESULT(yes) ],
+ [ AC_MSG_RESULT(no)
+ CFLAGS="$saved_CFLAGS" ]
+ )
+
if test -z "$have_llong_max"; then
# retry LLONG_MAX with -std=gnu99, needed on some Linuxes
unset ac_cv_have_decl_LLONG_MAX