summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2006-02-04 17:33:55 -0800
committerTim Rice <tim@multitalents.net>2006-02-04 17:33:55 -0800
commit0daad78fab0ff6b6b4064e3e7a5090d258d945a8 (patch)
tree7195c1285b2e90f66dc40d36c6e8a786ee3abfbd /configure.ac
parentfd80ddcb2349e2ac28f4fc6f682c20c8d1dc06ad (diff)
- (tim) [configure.ac] Add AC_REVISION. Add sys/time.h to lastlog.h test
for Solaris. OK dtucker@.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fe034aca..d64daf21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.324 2006/02/03 03:11:56 tim Exp $
+# $Id: configure.ac,v 1.325 2006/02/05 01:33:55 tim Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,6 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
+AC_REVISION($Revision: 1.325 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -673,7 +674,6 @@ AC_CHECK_HEADERS( \
glob.h \
ia.h \
iaf.h \
- lastlog.h \
limits.h \
login.h \
login_cap.h \
@@ -724,6 +724,13 @@ AC_CHECK_HEADERS( \
vis.h \
)
+# lastlog.h requires sys/time.h to be included first on Solaris
+AC_CHECK_HEADERS(lastlog.h, [], [], [
+#ifdef HAVE_SYS_TIME_H
+# include <sys/time.h>
+#endif
+])
+
# sys/ptms.h requires sys/stream.h to be included first on Solaris
AC_CHECK_HEADERS(sys/ptms.h, [], [], [
#ifdef HAVE_SYS_STREAM_H