summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2002-01-22 22:16:03 +1100
committerDamien Miller <djm@mindrot.org>2002-01-22 22:16:03 +1100
commitec932376b7c8bf621bb93ee6ee1406332e1574e1 (patch)
tree987cef3b3fa60de9f41633fc3fdc06ef20a23846 /configure.ac
parentc46cc5445dd9848c57318b3eb4fb7ca6a554839c (diff)
- (djm) autoconf hacking:
- Add OpenSSL sanity check: verify that header version matches version reported by library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9cc7dc97..966f8126 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-i# $Id: configure.ac,v 1.11 2002/01/22 10:57:54 djm Exp $
+i# $Id: configure.ac,v 1.12 2002/01/22 11:16:05 djm Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -812,6 +812,23 @@ else
fi
fi
+# Sanity check OpenSSL headers
+AC_MSG_CHECKING([whether OpenSSL's headers match the library])
+AC_TRY_RUN(
+ [
+#include <string.h>
+#include <openssl/opensslv.h>
+int main(void) { return(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); }
+ ],
+ [
+ AC_MSG_RESULT(yes)
+ ],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR(Your OpenSSL headers do not match your library)
+ ]
+)
+
# Some Linux systems (Slackware) need crypt() from libcrypt, *not* the
# version in OpenSSL. Skip this for PAM
if test "x$PAM_MSG" = "xno" -a "x$check_for_libcrypt_later" = "x1"; then