summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2002-01-23 08:12:36 +1100
committerDamien Miller <djm@mindrot.org>2002-01-23 08:12:36 +1100
commit6385ba0228516f937a0cd2322e9e064eeb68d856 (patch)
tree8b77015426d1f332ab8cc2cd41d3a6fbdba230ac /configure.ac
parentec52d7c0939569a5fa1ce531643da66508434486 (diff)
- (djm) Fix non-standard shell syntax in autoconf. Patch from
Dave Dykstra <dwd@bell-labs.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index de1c7f58..d002a338 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-i# $Id: configure.ac,v 1.13 2002/01/22 12:51:43 djm Exp $
+i# $Id: configure.ac,v 1.14 2002/01/22 21:12:37 djm Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -915,10 +915,12 @@ AC_ARG_WITH(prngd-socket,
if test ! -z "$PRNGD_PORT" ; then
AC_MSG_ERROR(You may not specify both a PRNGD/EGD port and socket)
fi
- if ! echo "$withval" | grep -q '^/' ; then
+ if echo "$withval" | grep '^/' >/dev/null 2>&1 ; then
+ # Good
+ else
AC_MSG_ERROR(You must specify an absolute path to the entropy socket)
fi
- if ! test -r "$withval" ; then
+ if test ! -r "$withval" ; then
AC_MSG_WARN(Entropy socket is not readable)
fi
PRNGD_SOCKET="$withval"