summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2002-02-13 23:06:56 +1100
committerDamien Miller <djm@mindrot.org>2002-02-13 23:06:56 +1100
commit150c8b557892f21ca87c5d36865d00724712c6a9 (patch)
tree49308a490f0d3320c658ff8136cb94b43b3f2a10 /configure.ac
parentdb95e4e1078cf1a8468ed7c245978ebd2ee5a979 (diff)
- (djm) Bug #106: Add --without-rpath configure option. Patch from
Nicolas.Williams@ubsw.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 80d3e48d..62eeac0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.17 2002/01/31 06:14:03 tim Exp $
+# $Id: configure.ac,v 1.18 2002/02/13 12:06:57 djm Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -333,6 +333,18 @@ fi
AC_CHECK_FUNC(getspnam, ,
AC_CHECK_LIB(gen, getspnam, LIBS="$LIBS -lgen"))
+AC_ARG_WITH(rpath,
+ [ --without-rpath Disable auto-added -R linker paths],
+ [
+ if test "x$withval" = "xno" ; then
+ need_dash_r=""
+ fi
+ if test "x$withval" = "xyes" ; then
+ need_dash_r=1
+ fi
+ ]
+)
+
dnl zlib is required
AC_ARG_WITH(zlib,
[ --with-zlib=PATH Use zlib in PATH],