summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordjm@openbsd.org <djm@openbsd.org>2020-03-13 03:17:07 +0000
committerDamien Miller <djm@mindrot.org>2020-03-14 19:39:09 +1100
commitd081f017c20a3564255873ed99fd7d024cac540f (patch)
tree961bd04b64c3d52803740987a6ab713e3ca6d06b /configure.ac
parentc084a2d040f160bc2b83f13297e3e3ca3f5dbac6 (diff)
upstream: spelling errors in comments; no code change from
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7094d470..a5c5c624 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3111,9 +3111,13 @@ if test "x$enable_sk" = "xyes" -a "x$enable_sk_internal" = "xyes" ; then
AC_DEFINE([ENABLE_SK_INTERNAL], [],
[Enable for built-in U2F/FIDO support])
enable_sk="built-in"
- ], [ ],
+ ], [ AC_MSG_ERROR([no usable libfido2 found]) ],
[ $OTHERLIBS ]
)
+ AC_CHECK_HEADER([fido.h], [],
+ AC_MSG_ERROR([missing fido.h from libfido2]))
+ AC_CHECK_HEADER([fido/credman.h], [],
+ AC_MSG_ERROR([missing fido/credman.h from libfido2]))
fi
AC_CHECK_FUNCS([ \