summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-09-11 14:42:55 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-09-11 14:42:55 +1000
commitc82afd5c8844c2cd5c411124fb077ca15dce6095 (patch)
tree4e45ba1e3f469cc3fd9a223ce01d367f89fc91ee /configure.ac
parent9a959ea1b5d59f8c3de9cb17c10dd2260117f877 (diff)
- (dtucker) [configure.ac] Bug #588, #615: Move other libgen tests to after
the dirname test, to allow a broken dirname to be detected correctly. Based partially on patch supplied by alex.kiernan at thus.net. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index cac1bbf2..d5d6f546 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.149 2003/09/10 05:22:45 dtucker Exp $
+# $Id: configure.ac,v 1.150 2003/09/11 04:42:56 dtucker Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -442,7 +442,7 @@ int main(){exit(0);}
# Checks for header files.
AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \
- getopt.h glob.h ia.h lastlog.h libgen.h limits.h login.h \
+ getopt.h glob.h ia.h lastlog.h limits.h login.h \
login_cap.h maillock.h netdb.h netgroup.h \
netinet/in_systm.h paths.h pty.h readpassphrase.h \
rpc/types.h security/pam_appl.h shadow.h stddef.h stdint.h \
@@ -463,9 +463,6 @@ if test "x$with_tcp_wrappers" != "xno" ; then
fi
fi
-AC_CHECK_FUNC(getspnam, ,
- AC_CHECK_LIB(gen, getspnam, LIBS="$LIBS -lgen"))
-
AC_ARG_WITH(rpath,
[ --without-rpath Disable auto-added -R linker paths],
[
@@ -676,7 +673,6 @@ AC_CHECK_FUNCS(\
)
AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP))
-AC_SEARCH_LIBS(basename, gen, AC_DEFINE(HAVE_BASENAME))
dnl Make sure prototypes are defined for these before using them.
AC_CHECK_DECL(strsep, [AC_CHECK_FUNCS(strsep)])
@@ -726,6 +722,10 @@ int main(int argc, char **argv) {
])
])
+AC_CHECK_FUNC(getspnam, ,
+ AC_CHECK_LIB(gen, getspnam, LIBS="$LIBS -lgen"))
+AC_SEARCH_LIBS(basename, gen, AC_DEFINE(HAVE_BASENAME))
+
dnl Checks for time functions
AC_CHECK_FUNCS(gettimeofday time)
dnl Checks for utmp functions