summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2003-05-15 11:12:19 +1000
committerDamien Miller <djm@mindrot.org>2003-05-15 11:12:19 +1000
commit9d2be48b8fe5c3f54e932e578e3029ebe0a773fb (patch)
treebca403c0625655134e895703d761f028426a8d36 /configure.ac
parent7abe09bf86b0ce437dfbf5dd7ccafadd1f39289e (diff)
better glue w/ jakob@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 7 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 000fb4bc..c8a99137 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.118 2003/05/15 00:53:49 djm Exp $
+# $Id: configure.ac,v 1.119 2003/05/15 01:12:19 djm Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1859,26 +1859,15 @@ AC_ARG_WITH(dns,
[ --with-dns Support for fetching keys from DNS (experimental)],
[
if test "x$withval" != "xno" ; then
- AC_DEFINE(DNS)
- DNS_MSG="yes"
- fi
- ]
-)
-
-LWRES_MSG=""
-AC_ARG_WITH(lwres,
- [ --with-lwres Use lwres library/headers for DNS support],
- [
- if test "x$withval" != "xno" -a "x$DNS_MSG" = "xyes"; then
- AC_DEFINE(LWRES)
- LWRES_MSG="(using liblwres)"
- AC_SEARCH_LIBS(lwres_herror, lwres)
+ DNS_MSG="no (system lacks getrrsetbyname)"
+ AC_SEARCH_LIBS(getrrsetbyname, resolv, [
+ AC_DEFINE(DNS)
+ DNS_MSG="yes"
+ ])
fi
]
)
-
-
# Check whether user wants Kerberos 5 support
KRB5_MSG="no"
AC_ARG_WITH(kerberos5,
@@ -2603,7 +2592,7 @@ if test ! -z "$superuser_path" ; then
echo " sshd superuser user PATH: $J"
fi
echo " Manpage format: $MANTYPE"
-echo " DNS support: $DNS_MSG $LWRES_MSG"
+echo " DNS support: $DNS_MSG"
echo " PAM support: $PAM_MSG"
echo " KerberosIV support: $KRB4_MSG"
echo " KerberosV support: $KRB5_MSG"