summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-09-22 11:08:00 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-09-22 11:08:00 +1000
commit31486b0beafa888af2018be7b639407e8cb34087 (patch)
tree38594bb7a8dd64f5d532992e2f672ea3717260c1 /configure.ac
parenta21ea0840c8040e17c120c972de03d780c9bd4a5 (diff)
- (dtucker) [configure.ac] Bug #655: uid swapping issues on Mac OS X.
Patch from max at quendi.de.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7ddcb777..32153be5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.154.2.1 2003/09/16 05:48:15 tim Exp $
+# $Id: configure.ac,v 1.154.2.2 2003/09/22 01:08:01 dtucker Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -131,6 +131,9 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
}], [AC_MSG_RESULT(working)],
[AC_MSG_RESULT(buggy)
AC_DEFINE(BROKEN_GETADDRINFO)],
+ AC_DEFINE(SETEUID_BREAKS_SETUID)
+ AC_DEFINE(BROKEN_SETREUID)
+ AC_DEFINE(BROKEN_SETREGID)
[AC_MSG_RESULT(assume it is working)])
;;
*-*-hpux10.26)