summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.local4
-rw-r--r--doc/man1/notmuch-address.rst2
-rw-r--r--doc/man1/notmuch-count.rst2
-rw-r--r--doc/man1/notmuch-search.rst2
-rw-r--r--doc/man1/notmuch-show.rst17
-rw-r--r--doc/notmuch-emacs.rst92
6 files changed, 107 insertions, 12 deletions
diff --git a/doc/Makefile.local b/doc/Makefile.local
index cb0f1f64..bab3d0d2 100644
--- a/doc/Makefile.local
+++ b/doc/Makefile.local
@@ -37,6 +37,10 @@ INFO_INFO_FILES := $(INFO_TEXI_FILES:.texi=.info)
%.gz: %
rm -f $@ && gzip --stdout $^ > $@
+ifeq ($(WITH_EMACS),1)
+$(DOCBUILDDIR)/.roff.stamp sphinx-html sphinx-texinfo: docstring.stamp
+endif
+
# Sequentialize the calls to sphinx-build to avoid races with
# reading/writing cached state. This uses GNU make specific
# "order-only" prerequisites.
diff --git a/doc/man1/notmuch-address.rst b/doc/man1/notmuch-address.rst
index 12d86e89..2a7df6f0 100644
--- a/doc/man1/notmuch-address.rst
+++ b/doc/man1/notmuch-address.rst
@@ -92,7 +92,7 @@ Supported options for **address** include
``--exclude=(true|false)``
A message is called "excluded" if it matches at least one tag in
- search.tag\_exclude that does not appear explicitly in the search
+ search.exclude\_tags that does not appear explicitly in the search
terms. This option specifies whether to omit excluded messages in
the search process.
diff --git a/doc/man1/notmuch-count.rst b/doc/man1/notmuch-count.rst
index 9ca20dab..0eac5dbe 100644
--- a/doc/man1/notmuch-count.rst
+++ b/doc/man1/notmuch-count.rst
@@ -36,7 +36,7 @@ Supported options for **count** include
same message-id).
``--exclude=(true|false)``
- Specify whether to omit messages matching search.tag\_exclude from
+ Specify whether to omit messages matching search.exclude\_tags from
the count (the default) or not.
``--batch``
diff --git a/doc/man1/notmuch-search.rst b/doc/man1/notmuch-search.rst
index 654c5f2c..ed9ff4e5 100644
--- a/doc/man1/notmuch-search.rst
+++ b/doc/man1/notmuch-search.rst
@@ -100,7 +100,7 @@ Supported options for **search** include
``--exclude=(true|false|all|flag)``
A message is called "excluded" if it matches at least one tag in
- search.tag\_exclude that does not appear explicitly in the search
+ search.exclude\_tags that does not appear explicitly in the search
terms. This option specifies whether to omit excluded messages in
the search process.
diff --git a/doc/man1/notmuch-show.rst b/doc/man1/notmuch-show.rst
index 8bfa87c6..becd3e79 100644
--- a/doc/man1/notmuch-show.rst
+++ b/doc/man1/notmuch-show.rst
@@ -161,7 +161,7 @@ Supported options for **show** include
Default: ``auto``
``--exclude=(true|false)``
- Specify whether to omit threads only matching search.tag\_exclude
+ Specify whether to omit threads only matching search.exclude\_tags
from the search results (the default) or not. In either case the
excluded message will be marked with the exclude flag (except when
output=mbox when there is nowhere to put the flag).
@@ -176,18 +176,19 @@ Supported options for **show** include
``--body=(true|false)``
If true (the default) **notmuch show** includes the bodies of the
messages in the output; if false, bodies are omitted.
- ``--body=false`` is only implemented for the json and sexp formats
- and it is incompatible with ``--part > 0.``
+ ``--body=false`` is only implemented for the text, json and sexp
+ formats and it is incompatible with ``--part > 0.``
This is useful if the caller only needs the headers as body-less
output is much faster and substantially smaller.
``--include-html``
- Include "text/html" parts as part of the output (currently only
- supported with ``--format=json`` and ``--format=sexp``). By default,
- unless ``--part=N`` is used to select a specific part or
- ``--include-html`` is used to include all "text/html" parts, no
- part with content type "text/html" is included in the output.
+ Include "text/html" parts as part of the output (currently
+ only supported with ``--format=text``, ``--format=json`` and
+ ``--format=sexp``). By default, unless ``--part=N`` is used to
+ select a specific part or ``--include-html`` is used to include all
+ "text/html" parts, no part with content type "text/html" is included
+ in the output.
A common use of **notmuch show** is to display a single thread of email
messages. For this, use a search term of "thread:<thread-id>" as can be
diff --git a/doc/notmuch-emacs.rst b/doc/notmuch-emacs.rst
index ce2e358e..0df46df9 100644
--- a/doc/notmuch-emacs.rst
+++ b/doc/notmuch-emacs.rst
@@ -62,6 +62,7 @@ notmuch-hello key bindings
``<return>``
Activate the current widget.
+``g``
``=``
Refresh the buffer; mainly update the counts of messages for various
saved searches.
@@ -159,6 +160,10 @@ menu of results that the user can explore further by pressing
``<return>``
Open thread on current line in :ref:`notmuch-show` mode
+``g``
+``=``
+ Refresh the buffer
+
``?``
Display full set of key bindings
@@ -190,6 +195,9 @@ pressing RET after positioning the cursor on a hidden part.
advance to the next message, or advance to the next thread (if
already on the last message of a thread).
+``c``
+ :ref:`show-copy`
+
``N``
Move to next message
@@ -208,6 +216,63 @@ pressing RET after positioning the cursor on a hidden part.
``?``
Display full set of key bindings
+Display of messages can be controlled by the following variables
+
+:index:`notmuch-message-headers`
+ |docstring::notmuch-message-headers|
+
+:index:`notmuch-message-headers-visible`
+ |docstring::notmuch-message-headers-visible|
+
+.. _show-copy:
+
+Copy to kill-ring
+-----------------
+
+You can use the usually Emacs ways of copying text to the kill-ring,
+but notmuch also provides some shortcuts. These keys are available in
+:ref:`notmuch-show`, and :ref:`notmuch-tree`. A subset are available
+in :ref:`notmuch-search`.
+
+``c F`` ``notmuch-show-stash-filename``
+ |docstring::notmuch-show-stash-filename|
+
+``c G`` ``notmuch-show-stash-git-send-email``
+ |docstring::notmuch-show-stash-git-send-email|
+
+``c I`` ``notmuch-show-stash-message-id-stripped``
+ |docstring::notmuch-show-stash-message-id-stripped|
+
+``c L`` ``notmuch-show-stash-mlarchive-link-and-go``
+ |docstring::notmuch-show-stash-mlarchive-link-and-go|
+
+``c T`` ``notmuch-show-stash-tags``
+ |docstring::notmuch-show-stash-tags|
+
+``c c`` ``notmuch-show-stash-cc``
+ |docstring::notmuch-show-stash-cc|
+
+``c d`` ``notmuch-show-stash-date``
+ |docstring::notmuch-show-stash-date|
+
+``c f`` ``notmuch-show-stash-from``
+ |docstring::notmuch-show-stash-from|
+
+``c i`` ``notmuch-show-stash-message-id``
+ |docstring::notmuch-show-stash-message-id|
+
+``c l`` ``notmuch-show-stash-mlarchive-link``
+ |docstring::notmuch-show-stash-mlarchive-link|
+
+``c s`` ``notmuch-show-stash-subject``
+ |docstring::notmuch-show-stash-subject|
+
+``c t`` ``notmuch-show-stash-to``
+ |docstring::notmuch-show-stash-to|
+
+``c ?``
+ Show all available copying commands
+
.. _notmuch-tree:
notmuch-tree
@@ -218,6 +283,9 @@ email archives. Each line in the buffer represents a single
message giving the relative date, the author, subject, and any
tags.
+``c``
+ :ref:`show-copy`
+
``<return>``
Displays that message.
@@ -233,6 +301,10 @@ tags.
``p``
Move to previous matching message
+``g``
+``=``
+ Refresh the buffer
+
``?``
Display full set of key bindings
@@ -275,7 +347,13 @@ operations specified in ``notmuch-tagging-keys``; i.e. each
:index:`notmuch-tagging-keys`
- A list of keys and corresponding tagging operations.
+ |docstring::notmuch-tagging-keys|
+
+Buffer navigation
+=================
+
+:index:`notmuch-cycle-notmuch-buffers`
+ |docstring::notmuch-cycle-notmuch-buffers|
Configuration
=============
@@ -286,8 +364,10 @@ Importing Mail
--------------
:index:`notmuch-poll`
+ |docstring::notmuch-poll|
:index:`notmuch-poll-script`
+ |docstring::notmuch-poll-script|
Init File
---------
@@ -300,3 +380,13 @@ suffix exist it will be read instead (just one of these, chosen in this
order). Most often users create ``~/.emacs.d/notmuch-config.el`` and just
work with it. If Emacs was invoked with the ``-q`` or ``--no-init-file``
options, ``notmuch-init-file`` is not read.
+
+.. include:: ../emacs/rstdoc.rsti
+
+.. include:: ../emacs/notmuch.rsti
+
+.. include:: ../emacs/notmuch-lib.rsti
+
+.. include:: ../emacs/notmuch-show.rsti
+
+.. include:: ../emacs/notmuch-tag.rsti