summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.local
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.local')
-rw-r--r--doc/Makefile.local8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.local b/doc/Makefile.local
index f53b3702..bab3d0d2 100644
--- a/doc/Makefile.local
+++ b/doc/Makefile.local
@@ -41,6 +41,14 @@ ifeq ($(WITH_EMACS),1)
$(DOCBUILDDIR)/.roff.stamp sphinx-html sphinx-texinfo: docstring.stamp
endif
+# Sequentialize the calls to sphinx-build to avoid races with
+# reading/writing cached state. This uses GNU make specific
+# "order-only" prerequisites.
+
+sphinx-html: | $(DOCBUILDDIR)/.roff.stamp
+sphinx-texinfo: | sphinx-html
+sphinx-info: | sphinx-texinfo
+
sphinx-html:
$(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(DOCBUILDDIR)/html