summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.global2
-rw-r--r--Makefile.local2
-rw-r--r--bindings/python-cffi/setup.py2
-rw-r--r--bindings/python-cffi/version.txt (renamed from bindings/python-cffi/version)0
-rw-r--r--doc/conf.py2
-rw-r--r--version.txt (renamed from version)0
6 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.global b/Makefile.global
index cd489ef2..8477468d 100644
--- a/Makefile.global
+++ b/Makefile.global
@@ -17,7 +17,7 @@ else
DATE:=$(shell date +%F)
endif
-VERSION:=$(shell cat ${srcdir}/version)
+VERSION:=$(shell cat ${srcdir}/version.txt)
ELPA_VERSION:=$(subst ~,_,$(VERSION))
ifeq ($(filter release release-message pre-release update-versions,$(MAKECMDGOALS)),)
ifeq ($(IS_GIT),yes)
diff --git a/Makefile.local b/Makefile.local
index c65cee7c..dde7981b 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -19,7 +19,7 @@ endif
# Depend (also) on the file 'version'. In case of ifeq ($(IS_GIT),yes)
# this file may already have been updated.
-version.stamp: $(srcdir)/version
+version.stamp: $(srcdir)/version.txt
echo $(VERSION) > $@
$(TAR_FILE):
diff --git a/bindings/python-cffi/setup.py b/bindings/python-cffi/setup.py
index b0060835..cda52338 100644
--- a/bindings/python-cffi/setup.py
+++ b/bindings/python-cffi/setup.py
@@ -1,6 +1,6 @@
import setuptools
-with open('version') as fp:
+with open('version.txt') as fp:
VERSION = fp.read().strip()
setuptools.setup(
diff --git a/bindings/python-cffi/version b/bindings/python-cffi/version.txt
index 48b9990e..48b9990e 100644
--- a/bindings/python-cffi/version
+++ b/bindings/python-cffi/version.txt
diff --git a/doc/conf.py b/doc/conf.py
index 94e266af..11bed51d 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -19,7 +19,7 @@ copyright = u'2009-2020, Carl Worth and many others'
location = os.path.dirname(__file__)
for pathdir in ['.', '..']:
- version_file = os.path.join(location,pathdir,'version')
+ version_file = os.path.join(location,pathdir,'version.txt')
if os.path.exists(version_file):
with open(version_file,'r') as infile:
version=infile.read().replace('\n','')
diff --git a/version b/version.txt
index 48b9990e..48b9990e 100644
--- a/version
+++ b/version.txt