summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-03-06 08:53:26 -0400
committerDavid Bremner <david@tethera.net>2019-03-06 08:53:26 -0400
commit71eaa19350883b30bafe885ea083c2e3f1621e10 (patch)
tree4991cb0b0ac8ab84177df05a2418fbd83e83051c /doc
parent872bd134e3ba860236661a202965a3d7447e7af7 (diff)
parentd124c0e416bb59cc4cbdca7694bae7097dcee810 (diff)
Merge branch 'release'
Changes from 0.28.3
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.local8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.local b/doc/Makefile.local
index f53b3702..bab3d0d2 100644
--- a/doc/Makefile.local
+++ b/doc/Makefile.local
@@ -41,6 +41,14 @@ ifeq ($(WITH_EMACS),1)
$(DOCBUILDDIR)/.roff.stamp sphinx-html sphinx-texinfo: docstring.stamp
endif
+# Sequentialize the calls to sphinx-build to avoid races with
+# reading/writing cached state. This uses GNU make specific
+# "order-only" prerequisites.
+
+sphinx-html: | $(DOCBUILDDIR)/.roff.stamp
+sphinx-texinfo: | sphinx-html
+sphinx-info: | sphinx-texinfo
+
sphinx-html:
$(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(DOCBUILDDIR)/html