summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-04-21 20:41:34 -0300
committerDavid Bremner <david@tethera.net>2019-04-24 06:53:13 -0300
commit40b025c5f1cc3dafe4c30cd6005fdb2ba32e0c95 (patch)
tree342743aad65f477f52bc5cde930531884513840d /doc
parente4a8d6e2a4355f54cb73d3b27afb0ce19ce7eb0d (diff)
doc: exclude notmuch-emacs.rst if emacs is not present.
This will still generate a warning about an excluded document in the toctree, but it cuts down on the noise quite a lot.
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.local2
-rw-r--r--doc/conf.py5
2 files changed, 6 insertions, 1 deletions
diff --git a/doc/Makefile.local b/doc/Makefile.local
index 57104dae..651168f4 100644
--- a/doc/Makefile.local
+++ b/doc/Makefile.local
@@ -4,7 +4,7 @@ dir := doc
# You can set these variables from the command line.
SPHINXOPTS := -q
-SPHINXBUILD = sphinx-build
+SPHINXBUILD = HAVE_EMACS=${HAVE_EMACS} sphinx-build
DOCBUILDDIR := $(dir)/_build
# Internal variables.
diff --git a/doc/conf.py b/doc/conf.py
index 0ef72327..5f8c9f1c 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -29,6 +29,11 @@ release = version
# directories to ignore when looking for source files.
exclude_patterns = ['_build']
+# If we don't have emacs, don't build the notmuch-emacs docs, as they need
+# emacs to generate the docstring include files
+if os.environ.get('HAVE_EMACS') != '1':
+ exclude_patterns.append('notmuch-emacs.rst')
+
# The name of the Pygments (syntax highlighting) style to use.
pygments_style = 'sphinx'