summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Kahn Gillmor <dkg@fifthhorseman.net>2019-12-23 17:17:22 -0500
committerDavid Bremner <david@tethera.net>2020-04-01 22:50:27 -0300
commit5bf5aa1cff84d54e72bfe9a92b46e166f2e7656e (patch)
treedffbe957664a73a69a78e354ca170737593573c9 /debian/rules
parentbd0b5abd5d6c6fe0c1a028192680f3a505a18ef2 (diff)
debian: Add packaging for python3-notmuch2
Ship a new debian package for the notmuch2 CFFI-based Python interface to notmuch. Unlike the notmuch python module, the new notmuch2 module is no longer arch-independent, because it builds and ships a shared object in addition to the python code. This patch encourages new downstream development to rely on notmuch2 instead of on notmuch, to get the benefits of the new module. I welcome any suggested improvements to this packaging, but it appears to me to be sufficient to get "import notmuch2" to work and do some basic tests.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index bf9d0bbd..8de49d0f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,5 @@
#!/usr/bin/make -f
-export PYBUILD_NAME=notmuch
-
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
@@ -19,17 +17,20 @@ override_dh_auto_configure:
override_dh_auto_build:
dh_auto_build -- V=1
- dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
+ PYBUILD_NAME=notmuch dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
+ PYBUILD_NAME=notmuch2 dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python-cffi
$(MAKE) -C contrib/notmuch-mutt
override_dh_auto_clean:
dh_auto_clean
- dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
+ PYBUILD_NAME=notmuch dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
+ PYBUILD_NAME=notmuch2 dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python-cffi
dh_auto_clean --sourcedirectory bindings/ruby
$(MAKE) -C contrib/notmuch-mutt clean
override_dh_auto_install:
dh_auto_install
- dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+ PYBUILD_NAME=notmuch dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+ PYBUILD_NAME=notmuch2 dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python-cffi
$(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
dh_auto_install --sourcedirectory bindings/ruby