summaryrefslogtreecommitdiffstats
path: root/bindings
diff options
context:
space:
mode:
authorFloris Bruynooghe <flub@devork.be>2020-06-19 11:46:28 +0200
committerDavid Bremner <david@tethera.net>2020-06-19 07:01:13 -0300
commit81057164cddf6a5c1d4c30a23767c4de8e615c1c (patch)
tree7da3ac1b9757e5a139b3cddb246dd527a96f6a3c /bindings
parentaf51e67127e5817e3795973da9c5e2148b7fdeec (diff)
python-cffi: read version from notmuch version file
This keeps it in sync with the main notmuch version which is less confusing to users.
Diffstat (limited to 'bindings')
-rw-r--r--bindings/python-cffi/setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/bindings/python-cffi/setup.py b/bindings/python-cffi/setup.py
index 37918e3d..1effcfc6 100644
--- a/bindings/python-cffi/setup.py
+++ b/bindings/python-cffi/setup.py
@@ -1,9 +1,17 @@
+import pathlib
+
import setuptools
+THIS_FILE = pathlib.Path(__file__).absolute()
+PROJECT_ROOT = THIS_FILE.parent.parent.parent
+with open(PROJECT_ROOT.joinpath('version')) as fp:
+ VERSION = fp.read().strip()
+
+
setuptools.setup(
name='notmuch2',
- version='0.1',
+ version=VERSION,
description='Pythonic bindings for the notmuch mail database using CFFI',
author='Floris Bruynooghe',
author_email='flub@devork.be',