summaryrefslogtreecommitdiffstats
path: root/bindings
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2020-06-29 21:22:47 -0300
committerDavid Bremner <david@tethera.net>2020-07-03 06:38:55 -0300
commit3a42abb456893b71b530f099a1467400f2b0ea71 (patch)
treefb1939c1b6fa036e9662ece45494b7abe954230d /bindings
parentf981f5bae0e33219b7e0e9f2d5e03d54d0d88cce (diff)
bindings/python-cffi: copy version file into bindings dir
Attempt to avoid breaking "pip install ." As far as I can tell, we need to have a copy (not just a relative symlink) of the version file.
Diffstat (limited to 'bindings')
-rw-r--r--bindings/python-cffi/setup.py8
-rw-r--r--bindings/python-cffi/version1
2 files changed, 2 insertions, 7 deletions
diff --git a/bindings/python-cffi/setup.py b/bindings/python-cffi/setup.py
index 1effcfc6..b0060835 100644
--- a/bindings/python-cffi/setup.py
+++ b/bindings/python-cffi/setup.py
@@ -1,14 +1,8 @@
-import pathlib
-
import setuptools
-
-THIS_FILE = pathlib.Path(__file__).absolute()
-PROJECT_ROOT = THIS_FILE.parent.parent.parent
-with open(PROJECT_ROOT.joinpath('version')) as fp:
+with open('version') as fp:
VERSION = fp.read().strip()
-
setuptools.setup(
name='notmuch2',
version=VERSION,
diff --git a/bindings/python-cffi/version b/bindings/python-cffi/version
new file mode 100644
index 00000000..71971d9b
--- /dev/null
+++ b/bindings/python-cffi/version
@@ -0,0 +1 @@
+0.30~rc2