summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorTomi Ollila <tomi.ollila@iki.fi>2017-01-16 20:04:48 +0200
committerDavid Bremner <david@tethera.net>2017-03-10 08:04:27 -0400
commitae05839028d59cbed09122752658543f68666423 (patch)
treec8d523ac8137431e282ac4f70b060dccdcc25698 /Makefile
parented22cd8bf14a652013dc7a17cf3a93f4e0ae911a (diff)
support make goals after initial {'', dist, data}clean goal(s)
Now make goal combinations starting with *clean goals, ending with *clean coals, and having non-*clean goals in between should work. What does not expected to work are non-*clean - *clean - *non-clean goal combinations. Also, if first goals are *clean goals, re-creation of Makefile.config is inhibited when Makefile.config exists and ./configure is newer.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0ef57fa9..d2010fe4 100644
--- a/Makefile
+++ b/Makefile
@@ -22,7 +22,35 @@ include Makefile.config
global_deps = Makefile Makefile.config Makefile.local \
$(subdirs:%=%/Makefile) $(subdirs:%=%/Makefile.local)
+INCLUDE_MORE := yes
+ifneq ($(filter clean distclean dataclean, $(word 1, $(MAKECMDGOALS))),)
+CLEAN_GOAL := $(word 1, $(MAKECMDGOALS))
+
+# If there are more goals following CLEAN_GOAL, run $(MAKE)s in parts.
+ifneq ($(word 2, $(MAKECMDGOALS)),)
+INCLUDE_MORE := no
+FOLLOWING_GOALS := $(wordlist 2, 99, $(MAKECMDGOALS))
+
+.PHONY: $(FOLLOWING_GOALS) make_in_parts
+$(FOLLOWING_GOALS):
+ @true
+$(CLEAN_GOAL): make_in_parts
+make_in_parts:
+ $(MAKE) $(CLEAN_GOAL)
+ $(MAKE) $(FOLLOWING_GOALS) configure_options="$(configure_options)"
+endif
+
+else
+CLEAN_GOAL :=
+endif
+
+# Potentially speedup make clean, distclean and dataclean ; avoid
+# re-creating Makefile.config if it exists but configure is newer.
+ifneq ($(CLEAN_GOAL),)
+Makefile.config: | $(srcdir)/configure
+else
Makefile.config: $(srcdir)/configure
+endif
ifeq ($(configure_options),)
@echo ""
@echo "Note: Calling ./configure with no command-line arguments. This is often fine,"
@@ -33,9 +61,11 @@ ifeq ($(configure_options),)
endif
$(srcdir)/configure $(configure_options)
+ifeq ($(INCLUDE_MORE),yes)
# runtime variable definitions available in all subdirs
include $(srcdir)/Makefile.global
# Finally, include all of the Makefile.local fragments where all the
# real work is done.
include $(subdirs:%=%/Makefile.local) Makefile.local
+endif