summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2016-11-19 13:44:28 -0400
committerDavid Bremner <david@tethera.net>2016-11-26 07:46:42 -0400
commit46a47f06a628c7025246da040fa9ab6301c49313 (patch)
tree3f6898e4139c8fbd2a838237ef90316420a895f5 /Makefile
parentd35c2c15f61cb527eea6e6224d8b0ad965100766 (diff)
build: Move variable definitions to Makefile.global
I noticed when trying to use VERSION (and derived variables) in a subdirectory that the top level Makefile.local needed to be included first. But according to c10085c77b407d9ea704f8b4f9e0a805f63e72cb it actually needs to be last. To break this conflict, move the variables definitions into a new Makefile.global.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4c0e8c62..0ef57fa9 100644
--- a/Makefile
+++ b/Makefile
@@ -33,6 +33,8 @@ ifeq ($(configure_options),)
endif
$(srcdir)/configure $(configure_options)
+# runtime variable definitions available in all subdirs
+include $(srcdir)/Makefile.global
# Finally, include all of the Makefile.local fragments where all the
# real work is done.