summaryrefslogtreecommitdiffstats
path: root/Makefile.local
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2017-03-14 08:10:07 -0300
committerDavid Bremner <david@tethera.net>2017-03-18 21:37:43 -0300
commitc39f6361d0798aa8d0dcd0b91f6b86ab9dc21c75 (patch)
tree6e62c880186ea60974847f525b253c670f6c851b /Makefile.local
parenta8a270522231b186493ecd97d56a1343382d51d8 (diff)
rename libutil.a to libnotmuch_util.a
Apparently some systems (MacOS?) have a system library called libutil and the name conflict causes problems. Since this library is quite notmuch specific, rename it to something less generic.
Diffstat (limited to 'Makefile.local')
-rw-r--r--Makefile.local2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.local b/Makefile.local
index e75b6eae..03eafaaa 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -241,7 +241,7 @@ notmuch_client_modules = $(notmuch_client_srcs:.c=.o)
notmuch.o: version.stamp
-notmuch: $(notmuch_client_modules) lib/libnotmuch.a util/libutil.a parse-time-string/libparse-time-string.a
+notmuch: $(notmuch_client_modules) lib/libnotmuch.a util/libnotmuch_util.a parse-time-string/libparse-time-string.a
$(call quiet,CXX $(CFLAGS)) $^ $(FINAL_LIBNOTMUCH_LDFLAGS) -o $@
notmuch-shared: $(notmuch_client_modules) lib/$(LINKER_NAME)