summaryrefslogtreecommitdiffstats
path: root/Makefile.local
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2017-03-01 20:44:47 -0400
committerDavid Bremner <david@tethera.net>2017-03-02 17:31:15 -0400
commit914c4db1f2cf5b19100b42a8e3ea62d000a9b642 (patch)
tree05f36b215884b89066f0c04a7ec98efe41cff87a /Makefile.local
parent4f2a7993a54dacbe5699f3d6195e13de2c1af2b5 (diff)
build: use sha256sum instead of sha1sum to sign releases
Diffstat (limited to 'Makefile.local')
-rw-r--r--Makefile.local9
1 files changed, 4 insertions, 5 deletions
diff --git a/Makefile.local b/Makefile.local
index 3548ed96..d2ef3e08 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -36,12 +36,11 @@ $(TAR_FILE):
gzip < $(TAR_FILE).tmp > $(TAR_FILE)
@echo "Source is ready for release in $(TAR_FILE)"
-$(SHA1_FILE): $(TAR_FILE)
- sha1sum $^ > $@
+$(SHA256_FILE): $(TAR_FILE)
+ sha256sum $^ > $@
-$(GPG_FILE): $(SHA1_FILE)
- @echo "Please enter your GPG password to sign the checksum."
- gpg --armor --sign $^
+$(GPG_FILE): $(SHA256_FILE)
+ gpg --armor --sign $^
.PHONY: dist
dist: $(TAR_FILE)