summaryrefslogtreecommitdiffstats
path: root/Makefile.global
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-10-28 15:44:35 +0100
committerDavid Bremner <david@tethera.net>2020-10-30 16:14:24 -0300
commit981d5a01689937ba45f3cd9dbdcdc65e6d264286 (patch)
tree0473295a82bb3b0eaa2e5c0c9ef086a14f0a1b76 /Makefile.global
parent582e919e2769bd99064b997b05e1601ffcfe9a98 (diff)
Rename version to version.txt
Building Notmuch on macOS is known to cause problems because the Notmuch distribution archive contains two files named "version". These names clash with the <version> header as defined in C++20. Therefore, the existing naming will likely become a problem on other platforms as well, once compilers adopt the new standard. Signed-off-by: Ralph Seichter <github@seichter.de> Amended-by: db s/keyword/header/ in commit message.
Diffstat (limited to 'Makefile.global')
-rw-r--r--Makefile.global2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.global b/Makefile.global
index cd489ef2..8477468d 100644
--- a/Makefile.global
+++ b/Makefile.global
@@ -17,7 +17,7 @@ else
DATE:=$(shell date +%F)
endif
-VERSION:=$(shell cat ${srcdir}/version)
+VERSION:=$(shell cat ${srcdir}/version.txt)
ELPA_VERSION:=$(subst ~,_,$(VERSION))
ifeq ($(filter release release-message pre-release update-versions,$(MAKECMDGOALS)),)
ifeq ($(IS_GIT),yes)