summaryrefslogtreecommitdiffstats
path: root/Makefile.global
diff options
context:
space:
mode:
authorTomi Ollila <tomi.ollila@iki.fi>2020-06-24 23:11:20 +0300
committerDavid Bremner <david@tethera.net>2020-06-26 21:48:56 -0300
commit751f6109225ccbe9a9008a2ff9381e4abfb4f71d (patch)
treeea9bcfe8197c3a761f538df1ab316355e6649749 /Makefile.global
parent81057164cddf6a5c1d4c30a23767c4de8e615c1c (diff)
Makefile.global: drop -std=gnu99. C11 (or later) compiler required
Since October 2018 building notmuch has actually required compiler that knows C11. Also this -std=gnu99 was not used in code compiled by configure, so in theory this could have caused problems... ...but no related reports have been sent, perhaps ever. Both gcc and clang has been shipping compilers supporting C11 (or later) by default for more than four years now. Therefore, just dropping -std=gnu99 (and not checking C11 compatibility for now, for simplicity) is easiest to do, and removes inconsistency between configure and build time compilations.
Diffstat (limited to 'Makefile.global')
-rw-r--r--Makefile.global3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.global b/Makefile.global
index 0aee5876..98b6962e 100644
--- a/Makefile.global
+++ b/Makefile.global
@@ -49,8 +49,7 @@ DETACHED_SIG_FILE=$(TAR_FILE).asc
PV_FILE=bindings/python/notmuch/version.py
# Smash together user's values with our extra values
-STD_CFLAGS := -std=gnu99
-FINAL_CFLAGS = -DNOTMUCH_VERSION=$(VERSION) $(CPPFLAGS) $(STD_CFLAGS) $(CFLAGS) $(WARN_CFLAGS) $(extra_cflags) $(CONFIGURE_CFLAGS)
+FINAL_CFLAGS = -DNOTMUCH_VERSION=$(VERSION) $(CPPFLAGS) $(CFLAGS) $(WARN_CFLAGS) $(extra_cflags) $(CONFIGURE_CFLAGS)
FINAL_CXXFLAGS = $(CPPFLAGS) $(CXXFLAGS) $(WARN_CXXFLAGS) $(extra_cflags) $(extra_cxxflags) $(CONFIGURE_CXXFLAGS)
FINAL_NOTMUCH_LDFLAGS = $(LDFLAGS) -Lutil -lnotmuch_util -Llib -lnotmuch
ifeq ($(LIBDIR_IN_LDCONFIG),0)