summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-02-17 17:08:12 -0400
committerDavid Bremner <david@tethera.net>2019-02-17 17:08:12 -0400
commitc09aad479464965f5296438eeb3afba0ec64d13b (patch)
tree2a8cb320950f05081063c6eccd99857ac280c243
parent3d0fd40eb0eca54fd05460203ae754c63f633d69 (diff)
parentaf0ff260cc1cb1c8ff0e5e353fd92ca4a1f2bc3f (diff)
Merge tag '0.28.2'
notmuch 0.28.2 release
-rw-r--r--NEWS14
-rw-r--r--bindings/python/docs/source/conf.py13
-rw-r--r--bindings/python/docs/source/filesystem.rst2
-rw-r--r--bindings/python/docs/source/threads.rst2
-rw-r--r--bindings/python/notmuch/version.py2
-rw-r--r--debian/changelog6
-rw-r--r--version2
7 files changed, 26 insertions, 15 deletions
diff --git a/NEWS b/NEWS
index d46035cd..2a69b0be 100644
--- a/NEWS
+++ b/NEWS
@@ -7,6 +7,20 @@ Command Line Interface
`notmuch show` now supports --body=false and --include-html with
--format=text
+Notmuch 0.28.2 (2019-02-17)
+===========================
+
+Emacs
+-----
+
+Invoke gpg with --batch and --no-tty.
+
+Python Bindings
+---------------
+
+Fix documentation build with Python 3.7. Note that Python >= 3.3 is
+now needed to build this documentation.
+
Notmuch 0.28.1 (2019-02-01)
===========================
diff --git a/bindings/python/docs/source/conf.py b/bindings/python/docs/source/conf.py
index 5b901c4e..8b43c5ca 100644
--- a/bindings/python/docs/source/conf.py
+++ b/bindings/python/docs/source/conf.py
@@ -13,22 +13,13 @@
import sys, os
+from unittest.mock import Mock
+
# If extensions (or modules to document with autodoc) are in another directory,
# add these directories to sys.path here. If the directory is relative to the
# documentation root, use os.path.abspath to make it absolute, like shown here.
sys.path.insert(0,os.path.abspath('../..'))
-class Mock(object):
- def __init__(self, *args, **kwargs):
- pass
-
- def __call__(self, *args, **kwargs):
- return Mock()
-
- @classmethod
- def __getattr__(self, name):
- return Mock() if name not in ('__file__', '__path__') else '/dev/null'
-
MOCK_MODULES = [
'ctypes',
]
diff --git a/bindings/python/docs/source/filesystem.rst b/bindings/python/docs/source/filesystem.rst
index 558c93de..13fe1194 100644
--- a/bindings/python/docs/source/filesystem.rst
+++ b/bindings/python/docs/source/filesystem.rst
@@ -15,7 +15,7 @@ Files and directories
instead.
:class:`Directory` -- A directory entry in the database
-------------------------------------------------------
+-------------------------------------------------------
.. autoclass:: Directory
diff --git a/bindings/python/docs/source/threads.rst b/bindings/python/docs/source/threads.rst
index 4324ac82..46ce5be5 100644
--- a/bindings/python/docs/source/threads.rst
+++ b/bindings/python/docs/source/threads.rst
@@ -11,4 +11,4 @@
iterator and broke list(Threads()). Use `len(list(msgs))`
instead.
-.. automethod:: __str__
+ .. automethod:: __str__
diff --git a/bindings/python/notmuch/version.py b/bindings/python/notmuch/version.py
index 7cc4db18..f376f6e6 100644
--- a/bindings/python/notmuch/version.py
+++ b/bindings/python/notmuch/version.py
@@ -1,3 +1,3 @@
# this file should be kept in sync with ../../../version
-__VERSION__ = '0.28.1'
+__VERSION__ = '0.28.2'
SOVERSION = '5'
diff --git a/debian/changelog b/debian/changelog
index fce3e5f3..9ed2547e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+notmuch (0.28.2-1) unstable; urgency=medium
+
+ * [notmuch-emacs] Invoke gpg from with --batch and --no-tty
+
+ -- David Bremner <bremner@debian.org> Sun, 17 Feb 2019 07:30:33 -0400
+
notmuch (0.28.1-1) unstable; urgency=medium
* New upstream bug fix release
diff --git a/version b/version
index 48f7a71d..a37255a8 100644
--- a/version
+++ b/version
@@ -1 +1 @@
-0.28.1
+0.28.2