summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-02-01 08:35:20 -0400
committerDavid Bremner <david@tethera.net>2019-02-01 08:35:20 -0400
commit87eb477ba546c47083f678bb7fa3d433cb591090 (patch)
tree64b93c83ece1fcc36958593bb09c1f96114c31ca
parent6784d5bc60f850a93e6101e60b03bf6ab81020cc (diff)
parent32fb3c420a408ccfd20301f0c527c4259bf721cc (diff)
Merge tag '0.28.1'
notmuch 0.28.1 release
-rw-r--r--NEWS9
-rw-r--r--bindings/python/notmuch/version.py2
-rwxr-xr-xconfigure8
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules2
-rw-r--r--doc/conf.py2
-rw-r--r--emacs/notmuch-print.el4
-rw-r--r--version2
8 files changed, 27 insertions, 10 deletions
diff --git a/NEWS b/NEWS
index 434f920a..d46035cd 100644
--- a/NEWS
+++ b/NEWS
@@ -7,6 +7,15 @@ Command Line Interface
`notmuch show` now supports --body=false and --include-html with
--format=text
+Notmuch 0.28.1 (2019-02-01)
+===========================
+
+Build System
+------------
+
+`configure` no longer uses the special variable BASH, as this causes
+problems on systems where /bin/sh is bash.
+
Notmuch 0.28 (2018-10-12)
=========================
diff --git a/bindings/python/notmuch/version.py b/bindings/python/notmuch/version.py
index 6a513a25..7cc4db18 100644
--- a/bindings/python/notmuch/version.py
+++ b/bindings/python/notmuch/version.py
@@ -1,3 +1,3 @@
# this file should be kept in sync with ../../../version
-__VERSION__ = '0.28'
+__VERSION__ = '0.28.1'
SOVERSION = '5'
diff --git a/configure b/configure
index 3ae26241..a6f5dfa2 100755
--- a/configure
+++ b/configure
@@ -53,7 +53,7 @@ fi
# Set several defaults (optionally specified by the user in
# environment variables)
-BASH=${BASH:-bash}
+BASHCMD=${BASHCMD:-bash}
PERL=${PERL:-perl}
CC=${CC:-cc}
CXX=${CXX:-c++}
@@ -560,13 +560,13 @@ else
fi
printf "Checking for bash... "
-if command -v ${BASH} > /dev/null; then
+if command -v ${BASHCMD} > /dev/null; then
have_bash=1
- bash_absolute=$(command -v ${BASH})
+ bash_absolute=$(command -v ${BASHCMD})
printf "Yes (%s).\n" "$bash_absolute"
else
have_bash=0
- printf "No. (%s not found)\n" "${BASH}"
+ printf "No. (%s not found)\n" "${BASHCMD}"
fi
printf "Checking for perl... "
diff --git a/debian/changelog b/debian/changelog
index 8f37ef3a..fce3e5f3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+notmuch (0.28.1-1) unstable; urgency=medium
+
+ * New upstream bug fix release
+ * Bug fix: "muttprint/evince fails to show "print", thanks to
+ Joerg Jaspert (Closes: #920856).
+
+ -- David Bremner <bremner@debian.org> Fri, 01 Feb 2019 08:05:05 -0400
+
notmuch (0.28-2) unstable; urgency=medium
* Override location of bash, because /usr/bin/bash might exist
diff --git a/debian/rules b/debian/rules
index c8ecb1ac..d056edb6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@ python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
dh $@ --with python2,python3,elpa
override_dh_auto_configure:
- BASH=/bin/bash ./configure --prefix=/usr \
+ BASHCMD=/bin/bash ./configure --prefix=/usr \
--libdir=/usr/lib/$$(dpkg-architecture -q DEB_TARGET_MULTIARCH) \
--includedir=/usr/include \
--mandir=/usr/share/man \
diff --git a/doc/conf.py b/doc/conf.py
index efbafc93..0ef72327 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -12,7 +12,7 @@ master_doc = 'index'
# General information about the project.
project = u'notmuch'
-copyright = u'2009-2018, Carl Worth and many others'
+copyright = u'2009-2019, Carl Worth and many others'
location = os.path.dirname(__file__)
diff --git a/emacs/notmuch-print.el b/emacs/notmuch-print.el
index bca759fa..d9b3d449 100644
--- a/emacs/notmuch-print.el
+++ b/emacs/notmuch-print.el
@@ -69,7 +69,7 @@ Optional OUTPUT allows passing a list of flags to muttprint."
(defun notmuch-print-ps-print/evince (msg)
"Preview a message buffer using ps-print and evince."
- (let ((ps-file (make-temp-file "notmuch"))
+ (let ((ps-file (make-temp-file "notmuch" nil ".ps"))
(subject (notmuch-prettify-subject
(plist-get (notmuch-show-get-prop :headers msg) :Subject))))
(rename-buffer subject t)
@@ -82,7 +82,7 @@ Optional OUTPUT allows passing a list of flags to muttprint."
(defun notmuch-print-muttprint/evince (msg)
"Preview a message buffer using muttprint and evince."
- (let ((ps-file (make-temp-file "notmuch")))
+ (let ((ps-file (make-temp-file "notmuch" nil ".ps")))
(notmuch-print-run-muttprint (list "--printer" (concat "TO_FILE:" ps-file)))
(notmuch-print-run-evince ps-file)))
diff --git a/version b/version
index 4950f07e..48f7a71d 100644
--- a/version
+++ b/version
@@ -1 +1 @@
-0.28
+0.28.1