summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-05-05 16:38:51 -0300
committerDavid Bremner <david@tethera.net>2019-05-05 16:38:51 -0300
commit6682b4e686b7972883626c9b0f941ae4bf02dedb (patch)
tree4330bb9dd97f6525f593925d927d655588ee5115
parent103c11822ee0b7645fda6397fb40f8ac7ed9b49b (diff)
parent93bd675c2a900b234536c5beaf0f7749e8fbe872 (diff)
Merge tag 0.28.4
No functionality changes merged, since the bug in question was already fixed on master.
-rw-r--r--NEWS9
-rw-r--r--bindings/python/notmuch/version.py2
-rw-r--r--debian/changelog9
-rwxr-xr-xtest/T210-raw.sh34
-rw-r--r--version2
5 files changed, 54 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 0a4ab4bb..26b8160c 100644
--- a/NEWS
+++ b/NEWS
@@ -13,6 +13,15 @@ Emacs
Support for GNU Emacs older than 25.1 is deprecated with this release,
and may be removed in a future release.
+Notmuch 0.28.4 (2019-05-05)
+===========================
+
+Command line interface
+----------------------
+
+Fix a spurious error when using `notmuch show --raw` on messages whose
+size is a multiple of the internal buffer size.
+
Notmuch 0.28.3 (2019-03-05)
===========================
diff --git a/bindings/python/notmuch/version.py b/bindings/python/notmuch/version.py
index 8217eabf..236751eb 100644
--- a/bindings/python/notmuch/version.py
+++ b/bindings/python/notmuch/version.py
@@ -1,3 +1,3 @@
# this file should be kept in sync with ../../../version
-__VERSION__ = '0.28.3'
+__VERSION__ = '0.28.4'
SOVERSION = '5'
diff --git a/debian/changelog b/debian/changelog
index 8afd985b..d0143a0f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+notmuch (0.28.4-1) unstable; urgency=medium
+
+ * New upstream bugfix release
+ * Fix for bug in 'notmuch show --raw' that causes spurious errors to be
+ reported when the mail file is a multiple of the libc buffer size
+ (e.g. 4096 bytes).
+
+ -- David Bremner <bremner@debian.org> Sun, 05 May 2019 08:08:56 -0300
+
notmuch (0.28.3-1) unstable; urgency=medium
* New upstream bugfix release.
diff --git a/test/T210-raw.sh b/test/T210-raw.sh
index 99fdef72..85e707d4 100755
--- a/test/T210-raw.sh
+++ b/test/T210-raw.sh
@@ -30,4 +30,38 @@ Date: GENERATED_DATE
This is just a test message (#2)"
+test_python <<EOF
+from email.message import EmailMessage
+for pow in range(10,21):
+ size = 2 ** pow
+ msg = EmailMessage()
+ msg['Subject'] = 'message with {:07d} bytes'.format(size)
+ msg['From'] = 'Notmuch Test Suite <test_suite@notmuchmail.org>'
+ msg['To'] = msg['From']
+ msg['Message-Id'] = 'size-{:07d}@notmuch-test-suite'.format(size)
+ content = ""
+ msg.set_content("")
+ padding = size - len(bytes(msg))
+ lines = []
+ while padding > 0:
+ line = '.' * min(padding, 72)
+ lines.append(line)
+ padding = padding - len(line) - 1
+ content ='\n'.join(lines)
+ msg.set_content(content)
+ with open('mail/size-{:07d}'.format(size), 'wb') as f:
+ f.write(bytes(msg))
+EOF
+
+notmuch new --quiet
+
+for pow in {10..20}; do
+ printf -v size "%07d" $((2**$pow))
+ test_begin_subtest "content, message of size $size"
+ notmuch show --format=raw subject:$size > OUTPUT
+ test_expect_equal_file mail/size-$size OUTPUT
+ test_begin_subtest "return value, message of size $size"
+ test_expect_success "notmuch show --format=raw subject:$size > /dev/null"
+done
+
test_done
diff --git a/version b/version
index b79f04f4..097bc936 100644
--- a/version
+++ b/version
@@ -1 +1 @@
-0.28.3
+0.28.4