summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2020-07-16 08:11:26 -0300
committerDavid Bremner <david@tethera.net>2020-08-03 20:44:51 -0300
commit3f8b01a3ef9e50a772897c67e0146172b3849749 (patch)
treed40a9886cb242196d47b94ba7ae4013c0142aa50
parent99a7aac8f2af6f3adb8f816be46ee33eb1d57515 (diff)
build: upload html docs as part of release process
Use a URL https://notmuchmail.org/doc/latest to leave room for a future more ambitious scheme deploying multiple versions. This also forces the html docs to built as part of the release process. In the future this should be updated to tolerate generating a release without sphinx installed. This needs a new target analogous to build-info and build-man that does nothing if sphinx is not installed.
-rw-r--r--Makefile.global1
-rw-r--r--Makefile.local3
2 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.global b/Makefile.global
index 98b6962e..4fd796e3 100644
--- a/Makefile.global
+++ b/Makefile.global
@@ -39,6 +39,7 @@ DEB_TAG=debian/$(UPSTREAM_TAG)-1
RELEASE_HOST=notmuchmail.org
RELEASE_DIR=/srv/notmuchmail.org/www/releases
+DOC_DIR=/srv/notmuchmail.org/www/doc/latest
RELEASE_URL=https://notmuchmail.org/releases
TAR_FILE=$(PACKAGE)-$(VERSION).tar.xz
ELPA_FILE:=$(PACKAGE)-emacs-$(ELPA_VERSION).tar
diff --git a/Makefile.local b/Makefile.local
index 22577617..39f36d50 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -64,7 +64,7 @@ update-versions:
# are part of the release and need to take the version from the
# version file).
.PHONY: release
-release: verify-source-tree-and-version
+release: verify-source-tree-and-version sphinx-html
$(MAKE) VERSION=$(VERSION) verify-newer
$(MAKE) VERSION=$(VERSION) clean
$(MAKE) VERSION=$(VERSION) test
@@ -80,6 +80,7 @@ ifeq ($(REALLY_UPLOAD),yes)
git push origin $(VERSION) $(DEB_TAG) release pristine-tar
cd releases && scp $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) $(RELEASE_HOST):$(RELEASE_DIR)
ssh $(RELEASE_HOST) "rm -f $(RELEASE_DIR)/LATEST-$(PACKAGE)-* ; ln -s $(TAR_FILE) $(RELEASE_DIR)/LATEST-$(TAR_FILE)"
+ rsync --verbose --delete --recursive doc/_build/html/ $(RELEASE_HOST):$(DOC_DIR)
endif
@echo "Please send a release announcement using $(PACKAGE)-$(VERSION).announce as a template."