summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2020-06-16 11:17:55 -0300
committerDavid Bremner <david@tethera.net>2020-07-03 07:37:00 -0300
commit552029f7482ea76806f18b8ef2cbe9c8706b39f4 (patch)
tree7bd907f6941c7daf044c10dcf4ec556989831cd8
parente9f8ffd882aba446ee27a9c32bb1e1475512d3f7 (diff)
build: produce signatures for release candidate tarballs.debian/0.30_rc3-10.30_rc3
Today Defalos on #notmuch asked for a signed tarball for 0.30~rc2. This is a minimal change to support this in the future. The question of automagically uploading will need more thought; currently I like the fact that tags from pre-releases are only pushed manually.
-rw-r--r--Makefile.local2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.local b/Makefile.local
index 314238ef..22577617 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -89,7 +89,7 @@ pre-release:
$(MAKE) VERSION=$(VERSION) test
git tag -s -m "$(PACKAGE) $(VERSION) release" $(UPSTREAM_TAG)
git tag -s -m "$(PACKAGE) Debian $(VERSION)-1 upload (same as $(VERSION))" $(DEB_TAG)
- $(MAKE) VERSION=$(VERSION) $(TAR_FILE)
+ $(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)
ln -sf $(TAR_FILE) $(DEB_TAR_FILE)
pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
mkdir -p releases