summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2020-11-08 13:33:08 -0400
committerDavid Bremner <david@tethera.net>2020-11-08 13:33:08 -0400
commit02a7b026d938f53d9fd9b183ca2b3c44c92489f2 (patch)
tree0b089c56417949b64f48743c3fe84ebe7271a4d4
parentbbe62623420a7f6c6e08730769ec63120da03dd0 (diff)
release: explicitely build sphinx-htmldebian/0.31.2-10.31.2
This is to force it to happen after the "make clean".
-rw-r--r--Makefile.local3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.local b/Makefile.local
index 205fc9d3..fb126294 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -64,9 +64,10 @@ update-versions:
# are part of the release and need to take the version from the
# version file).
.PHONY: release
-release: verify-source-tree-and-version sphinx-html
+release: verify-source-tree-and-version
$(MAKE) VERSION=$(VERSION) verify-newer
$(MAKE) VERSION=$(VERSION) clean
+ $(MAKE) VERSION=$(VERSION) sphinx-html
$(MAKE) VERSION=$(VERSION) test
git tag -s -m "$(PACKAGE) $(VERSION) release" $(UPSTREAM_TAG)
$(MAKE) VERSION=$(VERSION) $(SHA256_FILE) $(DETACHED_SIG_FILE)